SP w Piotrowicach Strona Główna SP w Piotrowicach
Forum Szkoły Podstawowej nr 3 w Piotrowicach

FAQFAQ  SzukajSzukaj  UżytkownicyUżytkownicy  GrupyGrupy
RejestracjaRejestracja  ZalogujZaloguj  AlbumAlbum

Poprzedni temat «» Następny temat
Instal'10
Autor Wiadomość
Greif 



Pomógł: 2 razy
Wiek: 42
Dołączył: 02 Paź 2007
Posty: 1577
Skąd: Piotrowice
Wysłany: 2009-10-28, 18:59   Instal'10

Etap szkolny - 21.10.2009

Utwórz procedurę AUTO1, wywołanie której spowoduje narysowanie na ekranie kształtu samochodu jak na Rysunku 1. Proporcje samochodu przedstawiono na tle siatki o rozmiarach 50 pkt. (siatka stanowi tylko ułatwienie analizy wymiarów elementów samochodu - nie należy jej definiować)



Z tego co widziałem, nie czytacie dokładnie poleceń, koła miały mieć bok 50, a nie 25. Auto miało mieć wysokość 100 a nie 200, a takie wymiary widziałem jak sprawdzałem prace. Osie kół miały być dokładnie pod "załamaniami" szyb z dachem i maską. Wszystko było punktowane.
No i pamiętać też trzeba o tym nieszczęsnym wzorze na przekątną kwadratu, bez którego tu się nie można było obyć.

Kto zrobi, niech wklei kod między znacznikami CODE.
_________________
Pozdrawiam
----------------------------------
 
 
faja94 
Użytkownik forum

Pomógł: 1 raz
Wiek: 23
Dołączył: 05 Lis 2007
Posty: 133
Skąd: Przeciszów
Wysłany: 2009-12-02, 18:18   

Kod:
oto skok :x :y
 pod np :x pw 90 np :y lw 90 opu
już

Kod:
oto auto1
 pw 90 np 50 lw 90 np 25 powtórz 3 [pw 90 np 50] pw 90 np 25
 skok 0 50 pw 90 np 12.5 lw 90 np 50 lw 90 np 50 pw 45 np 50 lw 45
 np 100 lw 45 np 50 lw 45 np 50
 lw 90 np 12.5 lw 90 np 25 powtórz 3 [ pw 90 np 50 ] pw 90 np 25
 skok 0 50 pw 90 np 50 lw 90
już
 
 
 
Greif 



Pomógł: 2 razy
Wiek: 42
Dołączył: 02 Paź 2007
Posty: 1577
Skąd: Piotrowice
Wysłany: 2009-12-05, 02:05   

Niestety auto niezbyt dobrze narysowane, ma wyglądać tak jak na obrazku, zwróć uwagę gdzie jest oś każdego koła. I przypominam o wzorze na przekątną kwadratu.
_________________
Pozdrawiam
----------------------------------
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group